A fix has been implemented and we are monitoring the results.
Posted Sep 12, 2025 - 10:07 UTC
Identified
We are currently experiencing finalization delays on the network. The issue has been identified and a fix has been implemented. We are monitoring the situation closely and will provide further updates as needed.
Posted Sep 12, 2025 - 05:38 UTC
This incident affected: Mainnet (Linea Mainnet L2->L1 Finalization).